Nota:
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
Este artículo le ayuda a resolver un problema de autenticación coherente con SQL Server que afecta al nombre de entidad de seguridad de servicio (SPN) explícito.
Síntomas
Si el SPN que especifique en el cadena de conexión existe en una cuenta de servicio que Microsoft SQL Server no usa, recibirá un mensaje de error de contexto de interfaz del proveedor de soporte técnico de seguridad (SSPI).
Si el SPN no está registrado correctamente, es posible que reciba el siguiente mensaje de error:
El nombre de la entidad de seguridad de destino es incorrecto. No se puede generar el contexto de SSPI.
Si intenta crear un SPN que ya existe, recibirá el siguiente mensaje de error:
SpN duplicado encontrado, operación de anulación!
Causa
Los SPN explícitos mal colocados pueden provocar problemas en la autenticación Kerberos y evitar que los clientes se conecten al servicio.
Solución
Si está experimentando SPN explícitos mal colocados, es posible que tenga que crear o volver a crear el SPN para el servicio. Para crear o volver a crear el SPN mediante el SETSPN comando , siga estos pasos:
- Ejecute el
SETSPN -L domain\svcacctcomando para enumerar los SPN en la cuenta de servicio de SQL Server. - Ejecute el
SETSPN -Q spnNamecomando para obtener información sobre la cuenta de servicio en la que está registrado el SPN. - Ejecute el
SETSPN -Dcomando para quitar el SPN del servicio. - Ejecute el
SETSPN -Acomando para agregar el SPN al servicio. - Mueva el SPN mediante
SETSPN -Do seleccione un SPN que ya exista en la cuenta correcta.