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Applies to: Power Automate
Summary
When you open Power Automate for desktop for the first time, you might receive a "Power Automate needs an update, but we're unable to apply the update right now" message. This problem typically occurs because the Windows Update service isn't running or is disabled. This article helps you resolve the problem by enabling the Windows Update service, running the Windows Update troubleshooter, or reinstalling Power Automate from the Microsoft Store.
Symptoms
When you try to open Power Automate for desktop for the first time, you receive the following message:
Power Automate needs an update, but we're unable to apply the update right now.
To verify the problem, check if you have an active internet connection and go to Windows Services to confirm that the Windows Update service isn't running.
Cause
This problem typically occurs when the Windows Update service isn't running or is disabled.
Solution
To resolve this problem, first check that you have an active internet connection, then try one of the following solutions:
Enable the Windows Update service
- Go to Windows Services and enable the Windows Update service.
- Launch Power Automate.
Run the Windows Update troubleshooter
- Open the Settings app in Windows.
- Select System > Troubleshoot > Other troubleshooters.
- Run the Windows Update troubleshooter and wait for it to complete.
- Launch Power Automate.
Reinstall Power Automate from the Microsoft Store
- Uninstall Power Automate.
- Open Microsoft Store and install Power Automate.