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This article discusses how to resolve the "ServiceUnavailable (409) error ("The requested resource is not available in the location" '<region-name>' at this moment")" that occurs when you try to deploy a resource in Microsoft Azure Container Instances.
Symptoms
You receive an error message that resembles the following text:
The requested resource is not available in the location '<region>' at this moment. Please retry with a different resource request or in another location. Resource requested: '2' CPU '4' GB memory 'Linux' OS virtual network. ServiceUnavailable (409).
Cause
This issue might occur if a feature isn't available in certain regions or if there's a lack of capacity. This issue is typically intermittent.
When container group deployment requests are larger than four (4) CPU or 16-GB memory the deployment is marked as Big Container Group. Big Container Group region capacity is enabled on demand and if there's no infrastructure available for the deployment the error is encountered.
Solution
- To determine whether you can deploy to an available region, see Resource availability & quota limits for Azure Container Instances.
- To determine which features are available in your region, use the Location - List Capabilities REST API. You can also verify available features per region by selecting the "Try it" button in that article.
- If you're deploying in an available region, and there's no feature limitation, retry the deployment.
- If you're deploying a Big Container Group, open a support ticket to validate region capacity.