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Container group remains in transitioning state

This article discusses how to resolve an operational failure that occurs when a container group remains in a transitioning state indefinitely in Microsoft Azure Container Instances. The article also discusses failures that occur during container group operations to start, restart, stop, or delete a container group.

Symptoms

When you issue a start/stop operation on a container group, you receive the following error message:

InternalErrorCode: "ContainerGroupTransitioning"
StatusCode: "409"
Message: "The container group '<container-group-name>' is still transitioning, please retry later."

Cause

Cause 1: After stop operation

During a continuous stop operation of the container group, system sidecar containers in the container group aren't terminated in time.

Cause 2: After start operation

The stopped state for previous operation wasn't propagated yet or didn't propagate correctly (known platform issue).

Solution 1

  • Wait until the container group is fully stopped to allow the system sidecars to fully terminate (allow at least 10 seconds between operations).
  • If the container is deployed by using an Azure Logic App, check the state of the container and then make sure the status is Stopped before issuing a start operation.
  • For job container groups (process runs once and exits, restart policy is Never) in Terminated state, issue a stop operation before a start operation to make sure the correct status is propagated first. You can also issue a restart operation. A restart operation avoids a new container group deployment and instead restarts the application process inside the container.

Note

As a best practice, we recommend that you always issue a stop operation before a start operation to ensure the correct status is propagated. If you start a container group that already has a running container, you might cause the transitioning state problem.

Solution 2: Open a support ticket

If the previous solutions don't fix the problem and you still encounter the error message, open a support ticket.

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